Below is the sample topology. It is important to note the interface numbers (ie Fa0/1 of each component). For reference I have numbered each component which will correspond to configurations below
Router>enable
Router#configure terminal
Router(config)#interface fa0/0
Router(config-if)#ip address 74.125.20.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fa0/1
Router(config-if)#ip address 74.125.15.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#iint fa0/1
Router(config-if)#ip nat inside
Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#ip nat inside source static 172.31.0.100 74.125.20.100
DNS configuration for the DNS server.
Turn the service on.
Enter the website name in the name box. Keep the record as A record
Enter the IP address of the DNS Server
Click Add
Configure the IP address as static 172.31.0.100 for the server 172.31.0.1 for the default gateway and 172.31.0.200 for the DNS Server
Router>enable
Router#configure terminal
Router(config)#interface fa0/1
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip dhcp pool FOC
Router(dhcp-config)#network 10.10.10.0 255.255.255.0
Router(dhcp-config)#default-router 10.10.10.1
Router(dhcp-config)#dns-server 172.31.0.200
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 10.10.10.1 10.10.10.10
Enabling DHCP snooping to prevent man in the middle attacks